Thank you, Olympus-Service! Good-bye PEN No. 548!

PEN No. 548

A few weeks ago, I bought an Olympus FL-300 R flash which – unfortunately – didn’t work when mounted to my PEN E-P3’s hotshoe. However in RC mode the unit worked fine and even on other PEN’s hothoes the flash behaved properly.

Actually, that didn’t bother me much since I bought the flash for off-camera lighting only. But when you spend some €’s on a brand new camera like the E-P3 and it seems to be the only camera the new flash doesn’t work with, you start to think twice. At least I did.

I posted this scenario on a german Olympus forum to see if other customers expected similar problems with their PENs/flashes, but based on this posting, I got contacted by the Olympus-Service Hamburg…

Since Olympus already heard of that problem, but wasn’t able to reproduce it with any of their own devices, they offered to provide me a working E-P3/FL-300R combo if I send them my devices for service and further investigations. Of course I agreed and just the next day an overnight-courier delivered the above camera with a working flash unit to me (before I was even able to send my package to Hamburg).

Good customer service so far, but furthermore Olympus was able to handle and repair my camera within less than 24 hours after they received it. So this whole process didn’t take longer than 5 days – THAT’S great service!

So I say “Thank you Olympus and good-bye PEN No.548!”

Advertisements

One Comment on “Thank you, Olympus-Service! Good-bye PEN No. 548!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s